Remote macOS computer disconnects after a restart from the login screen

Last updated on Sep 20, 2022

Problem

The remote macOS computer goes offline, then disconnects after a restart from the login screen.

Cause

This issue is associated with the default behavior of Apple macOS and occurs when working with the SetMe temporary client application running in User mode.

Solution

Run the remote client application as admin to avoid any disruptions and automatically reconnect to your session after a restart.

Affected operating systems:

  • macOS Mojave 10.14
  • macOS Catalina 10.15
  • macOS Big Sur 11
  • macOS Monterey 12