Remote macOS computer does not reconnect automatically after a restart

Last updated on Sep 20, 2022

Problem

The remote macOS computer does not automatically reconnect to the support session after a restart.

Cause

This issue is attributed to the default behavior of Apple macOS and occurs when working with the SetMe temporary client application running in User mode.

Solution

To restore the session, the remote user must agree with the confirmation prompt that appears upon logging back into the system:

You can also run the client application as admin to avoid any disruptions and automatically reconnect after a restart.

Affected operating systems:

  • macOS Mojave 10.14
  • macOS Catalina 10.15
  • macOS Big Sur 11
  • macOS Monterey 12